<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="distribution" content="global" />
	<meta name="robots" content="follow, all" />
	<meta name="language" content="en, sv" />
	<meta name="viewport" content="width=device-width" />
		<link rel="Shortcut Icon" href="https://thesuffolkjournal.com/wp-content/uploads/2016/06/SJ-Profile-Picture.jpg" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="The Suffolk Journal RSS 2.0" href="https://thesuffolkjournal.com/feed/" />
	<link rel="alternate" type="text/xml" title="The Suffolk Journal RSS .92" href="https://thesuffolkjournal.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="The Suffolk Journal Atom 0.3" href="https://thesuffolkjournal.com/feed/atom/" />
	<title>IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo &#8211; The Suffolk Journal</title>
<meta name='robots' content='max-image-preview:large' />
<link rel="alternate" type="application/rss+xml" title="The Suffolk Journal &raquo; IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo Comments Feed" href="https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thesuffolkjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://thesuffolkjournal.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://thesuffolkjournal.com/wp-includes/js/thickbox/thickbox.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thesuffolkjournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://thesuffolkjournal.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Portfolio-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/Total-Soft-Portfolio-Widget.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Portfolio2-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/Filt_popup.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/totalsoft.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://thesuffolkjournal.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7COpen+Sans%3A400%2C700%7CLato%3A400%2C700%7CBrawler%3A400%2C700%7CFjalla+One%3A400%2C700%7CExo%3A400%2C700&#038;display=swap&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/parallax/css/main.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/style.css?ver=9.4.43' type='text/css' media='all' />
<link rel='stylesheet' id='twp_styles-css'  href='https://thesuffolkjournal.com/wp-content/plugins/themes4wp-social-counter-widget/css/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='wp-paginate-css'  href='https://thesuffolkjournal.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.6' type='text/css' media='screen' />
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' id='Total_Soft_Portfolio-js-extra'>
/* <![CDATA[ */
var object = {"ajaxurl":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/JS/Total-Soft-Portfolio-Widget.js?ver=5.7.2' id='Total_Soft_Portfolio-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.7.2' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.7.2' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20210512' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20210512' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20210512' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.7.2' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.7.2' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.7.2' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.7.2' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20210512' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20210513' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.7.2' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://thesuffolkjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thesuffolkjournal.com/wp-json/wp/v2/posts/34287" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thesuffolkjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thesuffolkjournal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/" />
<link rel='shortlink' href='https://thesuffolkjournal.com/?p=34287' />
<link rel="alternate" type="application/json+oembed" href="https://thesuffolkjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesuffolkjournal.com%2F34287%2Fac%2Ffilm%2Fiffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thesuffolkjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesuffolkjournal.com%2F34287%2Fac%2Ffilm%2Fiffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo%2F&#038;format=xml" />
    <script src="https://apis.google.com/js/platform.js" async defer></script>
          <script>(function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
            fjs.parentNode.insertBefore(js, fjs);
          }(document, "script", "facebook-jssdk"));</script>
  <!-- This code is added by WP Analytify (4.0.3) https://analytify.io/downloads/analytify-wordpress-plugin/ !-->			<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
				(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
				m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})

			(window,document,'script','//www.google-analytics.com/analytics.js','ga');
				ga('create', 'UA-49077010-1', 'auto');ga('send', 'pageview');			</script>

			<!-- This code is added by WP Analytify (4.0.3) !-->

<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo" />
<meta property="og:type" content="article" />
<meta name="author" content="Imani Hill" />
<meta property="og:url" content="https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/" />
<meta property="og:image" content="https://thesuffolkjournal.com/wp-content/uploads/2021/05/sparks_001-900x506.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="506" />
	<meta property="og:site_name" content="The Suffolk Journal" />
	<meta property="og:description" content="With 25 albums, 50 years in the music business and 345 songs together Sparks is the rock duo that few people have heard of but thousands of musicians and artists have been inspired by. When I went to watch &#8220;The Sparks Brothers,&#8221; I thought it was just another mockumentary that was made by Edgar Wright,..." />
	<meta name="description" content="With 25 albums, 50 years in the music business and 345 songs together Sparks is the rock duo that few people have heard of but thousands of musicians and artists have been inspired by. When I went to watch &#8220;The Sparks Brothers,&#8221; I thought it was just another mockumentary that was made by Edgar Wright,..." />
	<meta property="article:section" content="Arts &amp; Culture" />
	<meta property="article:tag" content="IFFBoston" />
<!-- End of Open Graph Meta Tags -->

		<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
			var topmenuTop = jQuery('.navbarwrap').offset().top;
		topmenuTop -= wpadminbar;
		jQuery(window).scroll(function () {
			if (jQuery(this).scrollTop() > topmenuTop) {
				jQuery('#navbar .mini-logo').hide();
				jQuery('#show-mini-logo-top').fadeIn();
				if ( jQuery.isFunction(jQuery.fn.resizeMenuTop)) resizeMenuTop();
				
			} else {
				jQuery('#show-mini-logo-top').hide();
				jQuery('#navbar .mini-logo').fadeIn();
			}
		});
		
			var menuTop;
		if (jQuery('#subnavbar').length){
			var menuTop = jQuery('#subnavbar').offset().top;
		}
		menuTop -= wpadminbar;
		jQuery(window).scroll(function () {
			if (jQuery(this).scrollTop() > menuTop) {
				jQuery('#subnavbar .mini-logo').hide();
				jQuery('#show-mini-logo-bottom').fadeIn();
				if ( jQuery.isFunction(jQuery.fn.resizeMenuBottom)) resizeMenuBottom();
				
			} else {
				jQuery('#show-mini-logo-bottom').hide();
				jQuery('#subnavbar .mini-logo').fadeIn();
			}
		});
		
	
	});
</script>
<style type="text/css" media="screen">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</style></head>

<body data-rsssl=1 class="sno-animate-active">				<script type="text/javascript">
					jQuery(document).ready(function() {
						jQuery(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:0,
        					speed:2000    					});
					});
				</script><div class='navbarwrap'
						data-align='right' 
						data-margin='1' 
						data-style='Blocks' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='1290'><div class="navbarcontainer"><div id="navbar" class="sno-classic-menuwrap"><div id="navbarbackground"><div id="menu-a-menu"><nav aria-label="Secondary Menu"><div class="menu-top-menu-container"><ul id="menu-top-menu" class="sf-menu sno-top-menu"><li id="menu-item-6569" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6569"><a href="https://thesuffolkjournal.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-23199" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23199"><a href="https://thesuffolkjournal.com/about/awards-honors/">Awards &#038; Honors</a></li>
	<li id="menu-item-23626" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23626"><a href="https://thesuffolkjournal.com/standards-procedures/">Standards &#038; Procedures</a></li>
</ul>
</li>
<li id="menu-item-6564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6564"><a href="https://thesuffolkjournal.com/advertising/">Advertising</a>
<ul class="sub-menu">
	<li id="menu-item-6566" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6566"><a href="https://thesuffolkjournal.com/advertising/place-ad/">Place Ad</a></li>
	<li id="menu-item-6565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6565"><a href="https://thesuffolkjournal.com/advertising/media-kit/">Media Kit</a></li>
</ul>
</li>
<li id="menu-item-6568" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6568"><a href="https://thesuffolkjournal.com/contact/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-21580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21580"><a href="https://thesuffolkjournal.com/contact/send-us-a-tip/">Send Us a Tip</a></li>
	<li id="menu-item-21676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21676"><a href="https://thesuffolkjournal.com/contact/submit-a-letter-to-the-editor/">Submit a Letter to the Editor</a></li>
</ul>
</li>
<li id="menu-item-21673" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21673"><a href="https://thesuffolkjournal.com/join-the-journal/">Join The Journal</a></li>
<li id="menu-item-6567" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6567"><a href="https://thesuffolkjournal.com/archives/">Archives</a></li>
</ul></div><ul class='sno-menu-more sf-arrows' style='display:none'><li class='menu-more-item-top'><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a><ul class="sno-hac-menu-more"</ul></li></ul></nav></div></div></div></div></div><div class="clear"></div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://thesuffolkjournal.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-navigation" class="menu"><li id="menu-item-29807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29807"><a href="https://thesuffolkjournal.com/category/racial-justice/">Racial Justice</a></li>
<li id="menu-item-6527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6527"><a href="https://thesuffolkjournal.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-6535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6535"><a href="https://thesuffolkjournal.com/category/news/boston/">Boston</a></li>
	<li id="menu-item-6534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6534"><a href="https://thesuffolkjournal.com/category/news/campus/">Suffolk News</a></li>
	<li id="menu-item-28512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28512"><a href="https://thesuffolkjournal.com/category/news/this-week-in-sga/">This week in SGA&#8230;</a></li>
	<li id="menu-item-28723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28723"><a href="https://thesuffolkjournal.com/category/news/suffolk-firsts/">Suffolk Firsts</a></li>
	<li id="menu-item-33990" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33990"><a href="https://thesuffolkjournal.com/category/news/suffolk-magnified/">Suffolk Magnified</a></li>
</ul>
</li>
<li id="menu-item-6529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6529"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/">World</a>
<ul class="sub-menu">
	<li id="menu-item-32908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32908"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/cultural-groups-at-suffolk/">Cultural groups at Suffolk</a></li>
	<li id="menu-item-28500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28500"><a href="https://thesuffolkjournal.com/category/suffolk-climate-watch/">Suffolk Climate Watch</a></li>
</ul>
</li>
<li id="menu-item-20310" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-20310"><a href="https://thesuffolkjournal.com/category/ac/">Arts &amp; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-6538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6538"><a href="https://thesuffolkjournal.com/category/ac/artscampus/">Campus</a></li>
	<li id="menu-item-6537" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6537"><a href="https://thesuffolkjournal.com/category/ac/artsinboston/">Boston</a></li>
	<li id="menu-item-6536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6536"><a href="https://thesuffolkjournal.com/category/ac/music/">Music</a></li>
	<li id="menu-item-6539" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6539"><a href="https://thesuffolkjournal.com/category/ac/film/">Film</a></li>
	<li id="menu-item-6540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6540"><a href="https://thesuffolkjournal.com/category/ac/theater/">Theater</a></li>
	<li id="menu-item-32385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32385"><a href="https://thesuffolkjournal.com/category/ac/literature/">Literature</a></li>
	<li id="menu-item-32382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32382"><a href="https://thesuffolkjournal.com/category/ac/exhib/">Exhibits</a></li>
	<li id="menu-item-32383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32383"><a href="https://thesuffolkjournal.com/category/ac/fash/">Fashion</a></li>
	<li id="menu-item-32384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32384"><a href="https://thesuffolkjournal.com/category/ac/gaming/">Gaming</a></li>
</ul>
</li>
<li id="menu-item-6532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6532"><a href="https://thesuffolkjournal.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-32900" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32900"><a href="https://thesuffolkjournal.com/category/opinion/staff-editorial/">Staff Editorial</a></li>
	<li id="menu-item-32901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32901"><a href="https://thesuffolkjournal.com/category/opinion/student-and-the-city/">Student and the City</a></li>
	<li id="menu-item-32904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32904"><a href="https://thesuffolkjournal.com/category/opinion/letters-to-the-editor/">Letter to the Editor</a></li>
	<li id="menu-item-28494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28494"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-conservative-message/">The Conservative Message</a></li>
	<li id="menu-item-28495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28495"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-liberal-think-tank/">The Liberal Think Tank</a></li>
</ul>
</li>
<li id="menu-item-6531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6531"><a href="https://thesuffolkjournal.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-20524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20524"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/">Suffolk Rams</a>
	<ul class="sub-menu">
		<li id="menu-item-22158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22158"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/baseball/">Baseball</a></li>
		<li id="menu-item-22159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/basketball/">Basketball</a></li>
		<li id="menu-item-22160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/cross-country/">Cross Country</a></li>
		<li id="menu-item-22161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/golf/">Golf</a></li>
		<li id="menu-item-22162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/hockey/">Hockey</a></li>
		<li id="menu-item-22163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22163"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/soccer/">Soccer</a></li>
		<li id="menu-item-22164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22164"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/softball/">Softball</a></li>
		<li id="menu-item-22165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22165"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/tennis/">Tennis</a></li>
		<li id="menu-item-22166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22166"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/track/">Track &amp; Field</a></li>
		<li id="menu-item-22167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22167"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li id="menu-item-15147" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15147"><a href="https://thesuffolkjournal.com/category/sports/journalprosportscolumn/">Pro Sports</a></li>
</ul>
</li>
<li id="menu-item-24808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24808"><a href="https://thesuffolkjournal.com/category/multi-media/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-31685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31685"><a href="https://thesuffolkjournal.com/category/multi-media/suffolk-insider/">Suffolk Insider</a></li>
	<li id="menu-item-28645" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28645"><a href="https://suffolksnapshot.wordpress.com/">Suffolk Snapshot</a></li>
	<li id="menu-item-28996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28996"><a href="https://thesuffolkjournal.com/category/multi-media/comics/">Comics</a></li>
	<li id="menu-item-28847" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28847"><a href="https://thesuffolkjournal.com/category/multi-media/blast-from-the-past/">A blast from the past&#8230;</a></li>
</ul>
</li>
<li id="menu-item-29354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29354"><a href="https://thesuffolkjournal.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li id="menu-item-32907" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32907"><a href="https://thesuffolkjournal.com/category/politics/massachusetts-news/">Massachusetts News</a></li>
	<li id="menu-item-32906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32906"><a href="https://thesuffolkjournal.com/category/politics/national-news/">In the Nation</a></li>
	<li id="menu-item-32905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32905"><a href="https://thesuffolkjournal.com/category/politics/2020-election/">2020 Election</a></li>
</ul>
</li>
<li id="menu-item-29803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29803"><a href="https://thesuffolkjournal.com/category/the-suffolk-journal-podcast/">SJ Podcast</a></li>
<li id="menu-item-20412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20412"><a href="https://thesuffolkjournal.com/our-staff/">Staff</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://thesuffolkjournal.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-08-at-9.55.50-PM-2.png" class="headerimage" alt="Your School. Your Paper. Since 1936." /></div><div class="headerlink headermedium" style="display:none"><img src="https://thesuffolkjournal.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-08-at-9.55.50-PM-1.png" class="headerimage" alt="Your School. Your Paper. Since 1936." /></div><div class="headerlink headerlarge"><img src="https://thesuffolkjournal.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-08-at-9.55.50-PM-1.png" class="headerlink headerimage" alt="Your School. Your Paper. Since 1936." /></div><h1 style="display:none" aria-hidden="true">The Suffolk Journal</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://thesuffolkjournal.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://thesuffolkjournal.com"><img src="https://thesuffolkjournal.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-08-at-9.55.50-PM-1.png" class="headerimage" alt="Your School. Your Paper. Since 1936." /></a></div><h1 style="display:none">The Suffolk Journal</h1></div></div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='left' 
						data-margin='1' 
						data-style='Blocks' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='1290'><div class="subnavbarcontainer"><div id="subnavbar" class="sno-classic-menuwrap"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-navigation-container"><ul id="menu-navigation-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29807"><a href="https://thesuffolkjournal.com/category/racial-justice/">Racial Justice</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6527" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6535"><a href="https://thesuffolkjournal.com/category/news/boston/">Boston</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6534"><a href="https://thesuffolkjournal.com/category/news/campus/">Suffolk News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28512"><a href="https://thesuffolkjournal.com/category/news/this-week-in-sga/">This week in SGA&#8230;</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28723"><a href="https://thesuffolkjournal.com/category/news/suffolk-firsts/">Suffolk Firsts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33990"><a href="https://thesuffolkjournal.com/category/news/suffolk-magnified/">Suffolk Magnified</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6529" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/">World</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32908"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/cultural-groups-at-suffolk/">Cultural groups at Suffolk</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28500"><a href="https://thesuffolkjournal.com/category/suffolk-climate-watch/">Suffolk Climate Watch</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-20310" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/ac/">Arts &amp; Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6538"><a href="https://thesuffolkjournal.com/category/ac/artscampus/">Campus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6537"><a href="https://thesuffolkjournal.com/category/ac/artsinboston/">Boston</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6536"><a href="https://thesuffolkjournal.com/category/ac/music/">Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6539"><a href="https://thesuffolkjournal.com/category/ac/film/">Film</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6540"><a href="https://thesuffolkjournal.com/category/ac/theater/">Theater</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32385"><a href="https://thesuffolkjournal.com/category/ac/literature/">Literature</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32382"><a href="https://thesuffolkjournal.com/category/ac/exhib/">Exhibits</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32383"><a href="https://thesuffolkjournal.com/category/ac/fash/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32384"><a href="https://thesuffolkjournal.com/category/ac/gaming/">Gaming</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6532" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32900"><a href="https://thesuffolkjournal.com/category/opinion/staff-editorial/">Staff Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32901"><a href="https://thesuffolkjournal.com/category/opinion/student-and-the-city/">Student and the City</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32904"><a href="https://thesuffolkjournal.com/category/opinion/letters-to-the-editor/">Letter to the Editor</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28494"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-conservative-message/">The Conservative Message</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28495"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-liberal-think-tank/">The Liberal Think Tank</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6531" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20524" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/">Suffolk Rams</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22158"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/baseball/">Baseball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/basketball/">Basketball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/cross-country/">Cross Country</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/golf/">Golf</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/hockey/">Hockey</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22163"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/soccer/">Soccer</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22164"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/softball/">Softball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22165"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/tennis/">Tennis</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22166"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/track/">Track &amp; Field</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22167"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15147"><a href="https://thesuffolkjournal.com/category/sports/journalprosportscolumn/">Pro Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24808" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/multi-media/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31685"><a href="https://thesuffolkjournal.com/category/multi-media/suffolk-insider/">Suffolk Insider</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28645"><a href="https://suffolksnapshot.wordpress.com/">Suffolk Snapshot</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28996"><a href="https://thesuffolkjournal.com/category/multi-media/comics/">Comics</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28847"><a href="https://thesuffolkjournal.com/category/multi-media/blast-from-the-past/">A blast from the past&#8230;</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29354" aria-haspopup="true" aria-expanded="false" tabindex="0"><a href="https://thesuffolkjournal.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32907"><a href="https://thesuffolkjournal.com/category/politics/massachusetts-news/">Massachusetts News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32906"><a href="https://thesuffolkjournal.com/category/politics/national-news/">In the Nation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32905"><a href="https://thesuffolkjournal.com/category/politics/2020-election/">2020 Election</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29803"><a href="https://thesuffolkjournal.com/category/the-suffolk-journal-podcast/">SJ Podcast</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20412"><a href="https://thesuffolkjournal.com/our-staff/">Staff</a></li>
</ul></div><ul class='sno-menu-more sf-arrows' style='display:none'><li class='menu-more-item-top'><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a><ul class="sno-hac-menu-more"</ul></li></ul></nav></div></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div class="topnavwrap">
	<div id="topnavbar">
			
			<div class="search-spacer"></div>

			<div class="topnavbarleft classic-icon">
				<style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://thesuffolkjournal.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/thesuffolkjournal/">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/SuffolkJournal">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/suffolkjournal/?fref=ts">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   			</div>

			<div class="topnavbarcenter">
		        		            <script src="https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/date.js?ver=1" type="text/javascript"></script>
		        			</div>
	
			<div class="topnavbarright">
					<form method="get" id="searchform7840" action="https://thesuffolkjournal.com/">
			<div class="search-button-container" id="searchthis7840">
			<button type="submit" disabled="disabled" id="sno-search-navbar-7840" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s7840" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s7840" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit7840" style="display:none;" value="Search" />
		</form>
				</div>
			
	</div>
	<div class="clear"></div>
</div><div id="fullwrap" style="position:relative;"><div id="outerbackgroundwrap"><div class="innerbackgroundwrap "><div class="innerbackground"><div id='snopostid-34287' class='snopostid'><div id='storypage' class='full-width sno-story-34287'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 id="storyheadline" class="storyheadline">IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo</h1><div id="storymeta" class="storymeta"><p> <a href="https://thesuffolkjournal.com/staff_name/imani-hill/" class="creditline">Imani Hill</a>, Graduate Contributor<span class="storydate"><span class="byline-divider">|</span><span class="time-wrapper">May 19, 2021</span></span></p></div><div class="storyshadow"><div class="photowrap"><a class='modal-photo photooverlay' data-story-id='34287' data-photo-id='34288' href='#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/05/sparks_001-900x506.jpg' alt='%22The+Sparks+Brothers%22+directed+by+the+acclaimed+Edgar+Wright+was+included+in+this+year%27s+IFFBoston.' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photo photo-enlarge' data-story-id='34287' data-photo-id='34288'><i class='fas fa-search-plus'></i></div></div><div class="clear"></div><div class="captionboxmittop"><p class="photocredit"><a href="https://thesuffolkjournal.com/staff_name/iffboston/" class="creditline">IFFBoston</a></p><p class="photocaption">&#8220;The Sparks Brothers&#8221; directed by the acclaimed Edgar Wright was included in this year&#8217;s IFFBoston.</p></div></div><div class="sharing sharing-top" data-story-id="34287"><a class='commentscroll' href='https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-show'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthesuffolkjournal.com%2F34287%2Fac%2Ffilm%2Fiffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-show"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo&amp;url=https%3A%2F%2Fthesuffolkjournal.com%2F%3Fp%3D34287&amp;via=SuffolkJournal" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-show"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-show"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/?print=true"><div class="sharing-icon sno-print sharing-mobile-show"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div><span class="storycontent"><p><span style="font-weight: 400;">With 25 albums, 50 years in the music business and 345 songs together Sparks is the rock duo that few people have heard of but thousands of musicians and artists have been inspired by.</span></p>
<p><span style="font-weight: 400;">When I went to watch &#8220;The Sparks Brothers,&#8221; I thought it was just another mockumentary that was made by Edgar Wright, the director known for the British horror-comedy, “Shaun of the Dead.” I went in thinking it was just a spoof and that this band was somewhat strange with OK music, but I was wrong. </span></p>
<p><span style="font-weight: 400;">Sparks was founded by brothers Ron and Russell Mael in the 1960s. Their type of music is a mix of pop and rock, but their sound was ahead of their time and could easily make the Billboard Top 100 charts. </span></p>
<p><span style="font-weight: 400;">The film dived into the history behind them and how they went from being just a band named Halfnelson to The Sparks Brothers, to just Sparks. Famous bands like The Go-Go’s, Duran Duran to famous singers like Beck and “Weird Al” Yankovic were all inspired by the sound of the Mael brothers. </span></p>
<p><span style="font-weight: 400;">The story is about how people thought Sparks was a unique band from the U.K., but they really came from California. It dives into how they come up with the name of their albums and how their lyrics have double meanings.  </span></p>
<p><span style="font-weight: 400;">Bands from each decade in this film tell stories about their interaction with Sparks. They are just so funny and amazing. If there was a book about the stories that didn’t make it into the film, I would buy it. This film is something that I wish would come out on DVD so I could watch it every day. It was well directed by Wright and perfectly made. </span></p>
<p><span style="font-weight: 400;">Ron and Russell were also very funny in this film and their polar opposites are clear, unique and entertaining. What really makes the film so unique is the use of paintings, stop motion and claymation, for some reenactments that are used when the duo tells us their story. </span></p>
<p><span style="font-weight: 400;">I was blown away by just watching this movie with no prior knowledge of Sparks. But when the movie ended, I went on Spotify and Amazon Music just to listen for myself. I spent two hours and 34 minutes listening to their entire discography. My new favorite song from Sparks is “This Town Ain’t Big Enough For Both Of Us” from their album “</span><a href="https://music.amazon.com/albums/B001J18EO8?trackAsin=B001J15HWU&amp;ref=dm_sh_07ee-53aa-8e3e-2385-25188"><span style="font-weight: 400;">Kimono My House</span></a><span style="font-weight: 400;">.” </span></p>
<p><span style="font-weight: 400;">Overall, this film is one of the most entertaining documentaries at this year&#8217;s IFFBoston. If you watch this film, you too will become a fan of Sparks. Viewers will not be disappointed. </span></p>
<p><span style="font-weight: 400;">Check out the band on Instagram</span><a href="https://www.instagram.com/sparks_official/"><span style="font-weight: 400;"> @sparks_official</span></a><span style="font-weight: 400;">.</span></p>
<div id='video4242'  style="opacity:.4" class='videowidget center  background-white' style='border-color: #c6a141;'><div class='embedcontainer'><iframe loading="lazy" src="https://open.spotify.com/embed/artist/7pwjGKaqnfkvS7eQbHaqyH" width="300" height="380" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe></div></div><script type='text/javascript'>
		jQuery(document).ready(function() {
			jQuery(function () {
				jQuery(window).scroll(function () {
					var scrollTop4242     = jQuery(window).scrollTop(),
					elementOffset4242 = jQuery('#video4242').offset().top,
					distance4242      = (elementOffset4242 - scrollTop4242);
					if ((distance4242 < 400) && (distance4242 > 80)) {
						jQuery('#video4242').stop().animate({'opacity': '1'}, 'slow');

					} else {
						jQuery('#video4242').stop().animate({'opacity': '.4'}, 'slow'); 			
					}


				});
})

})
</script>				

</span></div><div class="clear"></div><ul class="snocategories"><li class='blockscategory'><a href='https://thesuffolkjournal.com/category/ac/' rel='category tag'>Arts &amp; Culture</a></li><li class='blockscategory'><a href='https://thesuffolkjournal.com/category/ac/artsinboston/' rel='category tag'>Boston</a></li><li class='blockscategory'><a href='https://thesuffolkjournal.com/category/ac/film/' rel='category tag'>Film</a></li></ul><ul class="snotags"><li class="blockstag"><a href="https://thesuffolkjournal.com/tag/iffboston/" rel="tag">IFFBoston</a></li></ul><div class="aboutwriter"><div class='aboutwritertitle'>About the Contributor</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/trythis-446x475.jpg' alt='Photo of Imani Hill'/></div><a href="https://thesuffolkjournal.com/staff_profile/imani-hill/"><div class='sc_title'>Imani Hill, Graduate Contributor | she/her </div></a><div class='sc_bio'><span style="font-weight: 400;">Imani Hill is a blogger, YouTuber, Instagramer and a wannabe comedian. She is very passionate about theater, films and TV shows. Imani is in Suffolk’s master program with a major in global public policy (dual degree). She loves to travel and try new things, and she is living her life one day at a time.</span><br />
<br />
Follow her on Twitter <a href="https://twitter.com/Joyqueen">@Joyqueen</a>.<div class='clear'></div></div></div><div class="clear"></div></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://thesuffolkjournal.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="34287" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://thesuffolkjournal.com/category/ac/">Arts &amp; Culture</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://thesuffolkjournal.com/34278/ac/film/iffboston-were-all-going-to-the-worlds-fair-is-a-disappointing-horror-film/" title="IFFBoston: &#8216;We’re All Going to the World’s Fair&#8217; is a disappointing horror film"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/05/weareall_001-240x150.jpg" class="catstory-photo" alt="Anna Cobb plays  teenager Casey, who becomes immersed in an online role-playing horror game. " /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/34278/ac/film/iffboston-were-all-going-to-the-worlds-fair-is-a-disappointing-horror-film/">IFFBoston: &#8216;We’re All Going to the World’s Fair&#8217; is a disappointing horror film</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://thesuffolkjournal.com/34270/ac/film/a-reckoning-in-boston-examines-racial-inequalities/" title="IFFBoston: &#8216;A Reckoning in Boston&#8217; examines racial inequalities"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/05/reckoning_002-240x150.png" class="catstory-photo" alt="James Rutenbeck's "A Reckoning in Boston" was shown at this year's virtual Independent Film Festival of Boston." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/34270/ac/film/a-reckoning-in-boston-examines-racial-inequalities/">IFFBoston: &#8216;A Reckoning in Boston&#8217; examines racial inequalities</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://thesuffolkjournal.com/34132/ac/artscampus/spring-fest-closes-the-semester-on-a-high-note/" title="Spring Fest closes the semester on a high note"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/DSC_5697-240x150.jpg" class="catstory-photo" alt="The hosts, Pat Lovelace and Mardochée Sylvestre, watching The Ramifications perform." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/34132/ac/artscampus/spring-fest-closes-the-semester-on-a-high-note/">Spring Fest closes the semester on a high note</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://thesuffolkjournal.com/34237/ac/music/suffolk-student-makes-album-from-dorm-room/" title="Suffolk student makes album from dorm room"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/image_6483441-2-240x150.jpg" class="catstory-photo" alt=""Disconnect" will be released on May 1." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/34237/ac/music/suffolk-student-makes-album-from-dorm-room/">Suffolk student makes album from dorm room</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://thesuffolkjournal.com/34207/opinion/opinion-thrifting-is-for-everyone-4-reasons-why-shopping-second-hand-is-ethical/" title="Opinion: Thrifting is for everyone, so here&#8217;s four reasons why shopping second hand is ethical"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/IMG_1610-240x150.jpeg" class="catstory-photo" alt="Two girls thrifting at a Goodwill in Boston." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/34207/opinion/opinion-thrifting-is-for-everyone-4-reasons-why-shopping-second-hand-is-ethical/">Opinion: Thrifting is for everyone, so here&#8217;s four reasons why shopping second hand is ethical</a></h5></div><div class="clear"></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://thesuffolkjournal.com/category/ac/artsinboston/">Boston</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://thesuffolkjournal.com/33874/ac/artsinboston/this-is-a-robbery-explores-bostons-biggest-mystery/" title="&#8216;This Is a Robbery&#8217; explores Boston&#8217;s biggest mystery"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/ISGMEmptyFrames-240x150.png" class="catstory-photo" alt="Frames still hang empty 30 years after thieves stole paintings from the Isabella Stewart Gardner Museum. " /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/33874/ac/artsinboston/this-is-a-robbery-explores-bostons-biggest-mystery/">&#8216;This Is a Robbery&#8217; explores Boston&#8217;s biggest mystery</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://thesuffolkjournal.com/33757/ac/artsinboston/heres-where-you-can-see-spring-bloom-in-boston/" title="Here&#8217;s where you can see spring bloom in Boston"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/IMG_0735-e1617754051540-240x150.jpg" class="catstory-photo" alt="Enjoy spring in the Public Garden!" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/33757/ac/artsinboston/heres-where-you-can-see-spring-bloom-in-boston/">Here&#8217;s where you can see spring bloom in Boston</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://thesuffolkjournal.com/33732/ac/artsinboston/bostons-ica-reopens-with-a-powerful-message/" title="Boston&#8217;s ICA reopens with a powerful message"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/04/IMG_5170-240x150.jpeg" class="catstory-photo" alt="The i’m yours: Encounters with Art in Our Times exhibit at the ICA is on display until May 23." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/33732/ac/artsinboston/bostons-ica-reopens-with-a-powerful-message/">Boston&#8217;s ICA reopens with a powerful message</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://thesuffolkjournal.com/33467/ac/artscampus/one-year-of-covid-how-the-boston-arts-has-adapted/" title="One year of COVID: How Boston arts has adapted"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/03/Boston-Theater-Flickr-240x150.jpg" class="catstory-photo" alt="Downtown Crossing is the heart of arts and culture in Boston." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/33467/ac/artscampus/one-year-of-covid-how-the-boston-arts-has-adapted/">One year of COVID: How Boston arts has adapted</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://thesuffolkjournal.com/33312/ac/artsinboston/mfas-monet-and-boston-lasting-impression-brings-warmth-to-the-city/" title="MFA&#8217;s &#8216;Monet and Boston: Lasting Impression&#8217; brings warmth to the city"><img src="https://thesuffolkjournal.com/wp-content/uploads/2021/03/10_The-Water-Lily-Pond-240x150.jpg" class="catstory-photo" alt="Claude Monet's "The Water Lily Pond," on display at the MFA through March 28." /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/33312/ac/artsinboston/mfas-monet-and-boston-lasting-impression-brings-warmth-to-the-city/">MFA&#8217;s &#8216;Monet and Boston: Lasting Impression&#8217; brings warmth to the city</a></h5></div><div class="clear"></div></div></div><div class="clear"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34278/ac/film/iffboston-were-all-going-to-the-worlds-fair-is-a-disappointing-horror-film/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/05/weareall_001-475x267.jpg' id='grow-stb34278'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Anna Cobb plays  teenager Casey, who becomes immersed in an online role-playing horror game. '/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34278').mouseenter(function() {
   											jQuery('#grow-stb34278').removeClass('shrink');
   											jQuery('#grow-stb34278').removeClass('grow');
   											jQuery('#grow-stb34278').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34278').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34278/ac/film/iffboston-were-all-going-to-the-worlds-fair-is-a-disappointing-horror-film/">IFFBoston: &#8216;We’re All Going to the World’s Fair&#8217; is a disappointing horror film</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34270/ac/film/a-reckoning-in-boston-examines-racial-inequalities/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/05/reckoning_002-475x267.png' id='grow-stb34270'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='James Rutenbeck's "A Reckoning in Boston" was shown at this year's virtual Independent Film Festival of Boston.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34270').mouseenter(function() {
   											jQuery('#grow-stb34270').removeClass('shrink');
   											jQuery('#grow-stb34270').removeClass('grow');
   											jQuery('#grow-stb34270').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34270').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34270/ac/film/a-reckoning-in-boston-examines-racial-inequalities/">IFFBoston: &#8216;A Reckoning in Boston&#8217; examines racial inequalities</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34132/ac/artscampus/spring-fest-closes-the-semester-on-a-high-note/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/DSC_5697-475x317.jpg' id='grow-stb34132'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The hosts, Pat Lovelace and Mardochée Sylvestre, watching The Ramifications perform.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34132').mouseenter(function() {
   											jQuery('#grow-stb34132').removeClass('shrink');
   											jQuery('#grow-stb34132').removeClass('grow');
   											jQuery('#grow-stb34132').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34132').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34132/ac/artscampus/spring-fest-closes-the-semester-on-a-high-note/">Spring Fest closes the semester on a high note</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34237/ac/music/suffolk-student-makes-album-from-dorm-room/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/image_6483441-2-475x475.jpg' id='grow-stb34237'  style='width:70px;min-width:70px;' class='catboxphoto' alt='"Disconnect" will be released on May 1.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34237').mouseenter(function() {
   											jQuery('#grow-stb34237').removeClass('shrink');
   											jQuery('#grow-stb34237').removeClass('grow');
   											jQuery('#grow-stb34237').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34237').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34237/ac/music/suffolk-student-makes-album-from-dorm-room/">Suffolk student makes album from dorm room</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34207/opinion/opinion-thrifting-is-for-everyone-4-reasons-why-shopping-second-hand-is-ethical/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/IMG_1610-475x267.jpeg' id='grow-stb34207'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Two girls thrifting at a Goodwill in Boston.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34207').mouseenter(function() {
   											jQuery('#grow-stb34207').removeClass('shrink');
   											jQuery('#grow-stb34207').removeClass('grow');
   											jQuery('#grow-stb34207').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34207').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34207/opinion/opinion-thrifting-is-for-everyone-4-reasons-why-shopping-second-hand-is-ethical/">Opinion: Thrifting is for everyone, so here&#8217;s four reasons why shopping second hand is ethical</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34159/ac/film/the-best-and-worst-moments-at-this-years-wild-oscars/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/Todd-Wawrychuk-A.M.P.A.S.-475x317.jpg' id='grow-stb34159'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Frances McDormand giving her speech after "Nomadland" won best picture.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34159').mouseenter(function() {
   											jQuery('#grow-stb34159').removeClass('shrink');
   											jQuery('#grow-stb34159').removeClass('grow');
   											jQuery('#grow-stb34159').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34159').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34159/ac/film/the-best-and-worst-moments-at-this-years-wild-oscars/">The best and worst moments at this year&#8217;s wild Oscars</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34164/ac/artscampus/suffolk-gallery-features-works-from-parts-of-nature/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/IMG_1789-475x356.jpeg' id='grow-stb34164'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Michelle Samour's drawings displayed at “Poetic Botany: Artists and Plants."'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34164').mouseenter(function() {
   											jQuery('#grow-stb34164').removeClass('shrink');
   											jQuery('#grow-stb34164').removeClass('grow');
   											jQuery('#grow-stb34164').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34164').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34164/ac/artscampus/suffolk-gallery-features-works-from-parts-of-nature/">Suffolk gallery features works from parts of nature</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34172/ac/artscampus/the-fact-of-a-body-author-speaks-to-suffolk-students/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/Goodreads-1-e1619566176666-304x475.jpg' id='grow-stb34172'  style='width:70px;min-width:70px;' class='catboxphoto' alt='“The Fact of a Body: A Murder and a Memior” is a true crime narrative about child murderer Ricky Langley.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34172').mouseenter(function() {
   											jQuery('#grow-stb34172').removeClass('shrink');
   											jQuery('#grow-stb34172').removeClass('grow');
   											jQuery('#grow-stb34172').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34172').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34172/ac/artscampus/the-fact-of-a-body-author-speaks-to-suffolk-students/">&#8216;The Fact of a Body&#8217; author speaks to Suffolk students</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34166/ac/world-trigger-has-a-strong-second-season/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/5dfc6de19f9f7-338x475.jpg' id='grow-stb34166'  style='width:70px;min-width:70px;' class='catboxphoto' alt='"World Trigger" will return with a third season in the fall.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34166').mouseenter(function() {
   											jQuery('#grow-stb34166').removeClass('shrink');
   											jQuery('#grow-stb34166').removeClass('grow');
   											jQuery('#grow-stb34166').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34166').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34166/ac/world-trigger-has-a-strong-second-season/">&#8216;World Trigger&#8217; has a strong second season</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://thesuffolkjournal.com/34152/ac/music/brockhamptons-new-album-is-perfect-for-summer/#photo'><img src='https://thesuffolkjournal.com/wp-content/uploads/2021/04/Brockhampton-2-475x317.jpg' id='grow-stb34152'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The 13-member Brockhampton collective released their new album "Roadrunner: New Light, New Machine" on April 9.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb34152').mouseenter(function() {
   											jQuery('#grow-stb34152').removeClass('shrink');
   											jQuery('#grow-stb34152').removeClass('grow');
   											jQuery('#grow-stb34152').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb34152').addClass('shrink');
   										});});</script><p class='stb-cat'>Arts &amp; Culture</p><p class="relatedtitle"><a href="https://thesuffolkjournal.com/34152/ac/music/brockhamptons-new-album-is-perfect-for-summer/">Brockhampton&#8217;s new album is perfect for summer</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 300,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div></div><div style="clear:both;"></div><div class="footerwrap footer_single"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://thesuffolkjournal.com">The Suffolk Journal</a></p></div><div class="footerright footer-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    	<a target="_blank" href="https://thesuffolkjournal.com/feed/rss/">
        	<div class="sno-icon social-border sno-rss">
	        	<i class="fa fa-rss"></i>
	        	<span class="icon-hidden-text">RSS Feed</span>
	        </div>
		</a>
        
        								   	    										
    
        				
   	    
    
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/thesuffolkjournal/">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/SuffolkJournal">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/suffolkjournal/?fref=ts">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div></div><div class="footertagline"><p>Your School. Your Paper. Since 1936.</p></div><div class="clear"></div><div class="footermenu"><div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="footer-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6569"><a href="https://thesuffolkjournal.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23199"><a href="https://thesuffolkjournal.com/about/awards-honors/">Awards &#038; Honors</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23626"><a href="https://thesuffolkjournal.com/standards-procedures/">Standards &#038; Procedures</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6564"><a href="https://thesuffolkjournal.com/advertising/">Advertising</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6566"><a href="https://thesuffolkjournal.com/advertising/place-ad/">Place Ad</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6565"><a href="https://thesuffolkjournal.com/advertising/media-kit/">Media Kit</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6568"><a href="https://thesuffolkjournal.com/contact/">Contact</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21580"><a href="https://thesuffolkjournal.com/contact/send-us-a-tip/">Send Us a Tip</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21676"><a href="https://thesuffolkjournal.com/contact/submit-a-letter-to-the-editor/">Submit a Letter to the Editor</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21673"><a href="https://thesuffolkjournal.com/join-the-journal/">Join The Journal</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6567"><a href="https://thesuffolkjournal.com/archives/">Archives</a></li>
</ul></div></div><div class="clear"></div><div class="footercredit"><div class="sno-footer-credit-inner"><a href="https://thesuffolkjournal.com">The Suffolk Journal</a> &bull; &copy; 2021 The Suffolk Journal &bull; <a target='_blank' href='http://www.suffolk.edu/studenthandbook/17544.php'>Privacy Policy</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://thesuffolkjournal.com/wp-login.php">Log in</a></div></div><div class="clear"></div></div></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-77199029-24', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	
<script type="text/javascript">
__tlid = '897596766940037121';
__tlconfig = {hOverflow: false, vOverflow: false};
setTimeout(function(){(function(d,t){var s=d.createElement(t),x=d.getElementsByTagName(t)[0];
s.type='text/javascript';s.async=true;s.src='//cdn.thinglink.me/jse/embed.js';
x.parentNode.insertBefore(s,x);})(document,'script');},0);
</script><div id="mobile-socialmedia"><div class="sharing sharing-top" data-story-id="34287"><a class='commentscroll' href='https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-show'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthesuffolkjournal.com%2F34287%2Fac%2Ffilm%2Fiffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-show"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo&amp;url=https%3A%2F%2Fthesuffolkjournal.com%2F%3Fp%3D34287&amp;via=SuffolkJournal" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-show"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-show"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/?print=true"><div class="sharing-icon sno-print sharing-mobile-show"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div></div><div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://thesuffolkjournal.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="34287"><a class='commentscroll' href='https://thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments  sharing-mobile-show'><i class='fa fa-comments-o'></i><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthesuffolkjournal.com%2F34287%2Fac%2Ffilm%2Fiffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook sharing-mobile-show"><i class="fa fa-facebook-f"></i><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo&amp;url=https%3A%2F%2Fthesuffolkjournal.com%2F%3Fp%3D34287&amp;via=SuffolkJournal" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter sharing-mobile-show"><i class="fa fa-twitter"></i><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email sharing-mobile-show"><i class="fa fa-envelope"></i><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//thesuffolkjournal.com/34287/ac/film/iffboston-the-sparks-brothers-is-a-salute-to-the-iconic-pop-rock-duo/?print=true"><div class="sharing-icon sno-print sharing-mobile-show"><i class="fa fa-print"></i><span class="icon-hidden-text">Print</span></div></a></div><div class="sharing-clear"></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="https://thesuffolkjournal.com"><div class="sno-home menu-icon dashicons dashicons-admin-home"><span class="icon-hidden-text">Home</span></div></a></div><div class="hover_title"><div class="hover_titletext">IFFBoston: &#8216;The Sparks Brothers&#8217; is a salute to the iconic pop-rock duo</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://thesuffolkjournal.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-navigation-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29807"><a href="https://thesuffolkjournal.com/category/racial-justice/">Racial Justice</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6527"><a href="https://thesuffolkjournal.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6535"><a href="https://thesuffolkjournal.com/category/news/boston/">Boston</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6534"><a href="https://thesuffolkjournal.com/category/news/campus/">Suffolk News</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28512"><a href="https://thesuffolkjournal.com/category/news/this-week-in-sga/">This week in SGA&#8230;</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28723"><a href="https://thesuffolkjournal.com/category/news/suffolk-firsts/">Suffolk Firsts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33990"><a href="https://thesuffolkjournal.com/category/news/suffolk-magnified/">Suffolk Magnified</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6529"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/">World</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32908"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/cultural-groups-at-suffolk/">Cultural groups at Suffolk</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28500"><a href="https://thesuffolkjournal.com/category/suffolk-climate-watch/">Suffolk Climate Watch</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-20310"><a href="https://thesuffolkjournal.com/category/ac/">Arts &amp; Culture</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6538"><a href="https://thesuffolkjournal.com/category/ac/artscampus/">Campus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6537"><a href="https://thesuffolkjournal.com/category/ac/artsinboston/">Boston</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6536"><a href="https://thesuffolkjournal.com/category/ac/music/">Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-6539"><a href="https://thesuffolkjournal.com/category/ac/film/">Film</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6540"><a href="https://thesuffolkjournal.com/category/ac/theater/">Theater</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32385"><a href="https://thesuffolkjournal.com/category/ac/literature/">Literature</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32382"><a href="https://thesuffolkjournal.com/category/ac/exhib/">Exhibits</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32383"><a href="https://thesuffolkjournal.com/category/ac/fash/">Fashion</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32384"><a href="https://thesuffolkjournal.com/category/ac/gaming/">Gaming</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6532"><a href="https://thesuffolkjournal.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32900"><a href="https://thesuffolkjournal.com/category/opinion/staff-editorial/">Staff Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32901"><a href="https://thesuffolkjournal.com/category/opinion/student-and-the-city/">Student and the City</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32904"><a href="https://thesuffolkjournal.com/category/opinion/letters-to-the-editor/">Letter to the Editor</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28494"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-conservative-message/">The Conservative Message</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28495"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-liberal-think-tank/">The Liberal Think Tank</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6531"><a href="https://thesuffolkjournal.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20524"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/">Suffolk Rams</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22158"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/baseball/">Baseball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/basketball/">Basketball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/cross-country/">Cross Country</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/golf/">Golf</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/hockey/">Hockey</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22163"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/soccer/">Soccer</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22164"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/softball/">Softball</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22165"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/tennis/">Tennis</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22166"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/track/">Track &amp; Field</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22167"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15147"><a href="https://thesuffolkjournal.com/category/sports/journalprosportscolumn/">Pro Sports</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24808"><a href="https://thesuffolkjournal.com/category/multi-media/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31685"><a href="https://thesuffolkjournal.com/category/multi-media/suffolk-insider/">Suffolk Insider</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28645"><a href="https://suffolksnapshot.wordpress.com/">Suffolk Snapshot</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28996"><a href="https://thesuffolkjournal.com/category/multi-media/comics/">Comics</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28847"><a href="https://thesuffolkjournal.com/category/multi-media/blast-from-the-past/">A blast from the past&#8230;</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-29354"><a href="https://thesuffolkjournal.com/category/politics/">Politics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32907"><a href="https://thesuffolkjournal.com/category/politics/massachusetts-news/">Massachusetts News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32906"><a href="https://thesuffolkjournal.com/category/politics/national-news/">In the Nation</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32905"><a href="https://thesuffolkjournal.com/category/politics/2020-election/">2020 Election</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29803"><a href="https://thesuffolkjournal.com/category/the-suffolk-journal-podcast/">SJ Podcast</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20412"><a href="https://thesuffolkjournal.com/our-staff/">Staff</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
				// disabling this feature when using new scrollToFix elements in header
				if( jQuery('.sno-header-row-stick').length ) return;
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
									sharingIconsResize();
					
					jQuery(window).resize(function() {
						sharingIconsResize();
					});
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footerwrap').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
				
/*
				jQuery('.sno-menu').click(function() {
				
					jQuery('#hoverbar_menu').fadeToggle();
					jQuery('.menu-icon').toggle();
					jQuery('.close-icon').toggle();
					jQuery('#hoverbar_menu').css({ height: jQuery(window).height() - 50 });
				
				});
*/
				
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
	
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
/*
					if ( ScrollPercent > 100 ) {
												jQuery('.sno-arrow-up').css({ background: '#142f53', color: '#eee'});
						jQuery('.sno-menu').css({ background: '#142f53', color: '#eee'});
						jQuery('.socialmedia .sharing-icon').css({ opacity: 1 })
						
							
					} else {
												jQuery('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
						jQuery('.sno-menu').css({ background: '#eee', color: '#ccc'});
					}
*/
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script><div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thesuffolkjournal.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
</div></body></html>