<!DOCTYPE html>
<html style="margin:0px!important;">
<head>
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes">
<link rel="Shortcut Icon" href="https://thesuffolkjournal.com/wp-content/uploads/2016/06/SJ-Profile-Picture.jpg" type="image/x-icon" />
<title>The Suffolk Journal | Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either</title>

<title>Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either &#8211; The Suffolk Journal</title>
<link rel="alternate" type="application/rss+xml" title="The Suffolk Journal &raquo; Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either Comments Feed" href="https://thesuffolkjournal.com/31519/opinion/opinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thesuffolkjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='farbtastic-css'  href='https://thesuffolkjournal.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://thesuffolkjournal.com/wp-includes/css/dashicons.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://thesuffolkjournal.com/wp-includes/js/thickbox/thickbox.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://thesuffolkjournal.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://thesuffolkjournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='ctf_styles-css'  href='https://thesuffolkjournal.com/wp-content/plugins/custom-twitter-feeds/css/ctf-styles.min.css?ver=1.6' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Portfolio-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/Total-Soft-Portfolio-Widget.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='Total_Soft_Portfolio2-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/Filt_popup.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/CSS/totalsoft.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://thesuffolkjournal.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.5' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7COpen+Sans%3A400%2C700%7CLato%3A400%2C700%7CBrawler%3A400%2C700%7CFjalla+One%3A400%2C700%7CExo%3A400%2C700&#038;display=swap&#038;ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/parallax/css/main.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://thesuffolkjournal.com/wp-content/themes/snoflex/style.css?ver=9.0.167' type='text/css' media='all' />
<link rel='stylesheet' id='twp_styles-css'  href='https://thesuffolkjournal.com/wp-content/plugins/themes4wp-social-counter-widget/css/style.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://thesuffolkjournal.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.2' type='text/css' media='screen' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script type='text/javascript' id='Total_Soft_Portfolio-js-extra'>
/* <![CDATA[ */
var object = {"ajaxurl":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/plugins/gallery-portfolio/JS/Total-Soft-Portfolio-Widget.js?ver=5.5.3' id='Total_Soft_Portfolio-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.5.3' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.5.3' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20200802' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20200803' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20200803' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.5.3' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.5.3' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.5.3' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.5.3' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20190826' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20200702' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.5.3' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://thesuffolkjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thesuffolkjournal.com/wp-json/wp/v2/posts/31519" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thesuffolkjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thesuffolkjournal.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Suffolk announces no in-person classes after Thanksgiving break, Kelly cites concerns of holiday gatherings' href='https://thesuffolkjournal.com/31500/news/suffolk-announces-no-in-person-classes-held-after-thanksgiving-break-kelly-cites-concerns-of-holiday-gatherings/' />
<link rel='next' title='Suffolk Journal 2020 Election Map; Election still undecided' href='https://thesuffolkjournal.com/31373/politics/suffolk-journal-2020-election-map/' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://thesuffolkjournal.com/31519/opinion/opinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either/" />
<link rel='shortlink' href='https://thesuffolkjournal.com/?p=31519' />
<link rel="alternate" type="application/json+oembed" href="https://thesuffolkjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesuffolkjournal.com%2F31519%2Fopinion%2Fopinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thesuffolkjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthesuffolkjournal.com%2F31519%2Fopinion%2Fopinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either%2F&#038;format=xml" />
    <script src="https://apis.google.com/js/platform.js" async defer></script>
          <script>(function(d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id;
            js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5";
            fjs.parentNode.insertBefore(js, fjs);
          }(document, "script", "facebook-jssdk"));</script>
  <!-- This code is added by WP Analytify (3.1.5) https://analytify.io/downloads/analytify-wordpress-plugin/ !-->				 <script>
				 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
					 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
					 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
				 })

				 (window,document,'script','//www.google-analytics.com/analytics.js','ga');
				 	ga('create', 'UA-49077010-1', 'auto');ga('send', 'pageview');				 </script>

				 <!-- This code is added by WP Analytify (3.1.5) !-->

<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either" />
<meta property="og:type" content="article" />
<meta name="author" content="Morgan Torre" />
<meta property="og:url" content="https://thesuffolkjournal.com/31519/opinion/opinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either/" />
<meta property="og:image" content="https://thesuffolkjournal.com/wp-content/uploads/2020/10/lgbt-pride-flag-redesign-hero-900x507.jpg" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="507" />
	<meta property="og:site_name" content="The Suffolk Journal" />
	<meta property="og:description" content="With a viral video of First Lady Melania Trump defending her husband’s contradicting stance on gay marriage circulating the week of the election, President Donald Trump’s opposition to gay marriage is being magnified, creating further stress for all members of the LGBTQ+ community and their allies. “I was shocked to discover that some of these..." />
	<meta name="description" content="With a viral video of First Lady Melania Trump defending her husband’s contradicting stance on gay marriage circulating the week of the election, President Donald Trump’s opposition to gay marriage is being magnified, creating further stress for all members of the LGBTQ+ community and their allies. “I was shocked to discover that some of these..." />
	<meta property="article:section" content="Opinion" />
	<meta property="article:tag" content="" />
<!-- End of Open Graph Meta Tags -->

<style type="text/css" media="screen">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</style></head>
<body data-rsssl=1>


<div id="lf_wrap">
<div id='snopostid-31519' class='snopostid'>
<div id="sno_longform" class="sno-story-31519">
	
		<style>
				#wpadminbar {display:none!important;}
			</style><div class='header' style='display:none;'><div class="altheader-menu"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"></div></div></div><div class="lf_headerleft"><a href="/"><img src="https://thesuffolkjournal.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-08-at-9.55.50-PM-2.png" alt="Your School. Your Paper. Since 1936." /></a></div><div class="socialmedia"><div class="sharing sharing-top" data-story-id="31519"><a class='commentscroll' href='https://thesuffolkjournal.com/31519/opinion/opinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either/#respond ' title='Jump to Comments'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-show'><span class='icon-hidden-text'>Jump to Comments</span></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fthesuffolkjournal.com%2F31519%2Fopinion%2Fopinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-show"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either&amp;url=https%3A%2F%2Fthesuffolkjournal.com%2F%3Fp%3D31519&amp;via=SuffolkJournal" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-show"><span class="icon-hidden-text">Share on Twitter</span></div></a><a href="#" onclick="return false;" class="modal-share share-email"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-show"><span class="icon-hidden-text">Share via Email</span></div></a><a rel="nofollow" href="//thesuffolkjournal.com/31519/opinion/opinion-trump-wont-protect-my-gay-mom-and-he-wont-protect-your-lgbtq-friends-either/?print=true"><div class="sharing-icon sno-print fa fa-print sno-dark sharing-mobile-show"><span class="icon-hidden-text">Print</span></div></a></div></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"></div></a></div></div>
<div id="storypage">
<div id="altheader-searchbox"><ul class="slidemenu mobile-menu"><li class="mobile-search" style="margin-top: 0px; clear: both;"><form method="get" id="searchform-alt" action="https://thesuffolkjournal.com/">
									<label for="s" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
								</form></li><div class="mobile-menu"><ul id="menu-navigation" class="menu"><li id="menu-item-29807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29807"><a href="https://thesuffolkjournal.com/category/racial-justice/">Racial Justice</a></li>
<li id="menu-item-6527" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6527"><a href="https://thesuffolkjournal.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-6535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6535"><a href="https://thesuffolkjournal.com/category/news/boston/">Boston</a></li>
	<li id="menu-item-6534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6534"><a href="https://thesuffolkjournal.com/category/news/campus/">Suffolk News</a></li>
	<li id="menu-item-28512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28512"><a href="https://thesuffolkjournal.com/category/news/this-week-in-sga/">This week in SGA&#8230;</a></li>
	<li id="menu-item-28723" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28723"><a href="https://thesuffolkjournal.com/category/news/suffolk-firsts/">Suffolk Firsts</a></li>
</ul>
</li>
<li id="menu-item-6529" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6529"><a href="https://thesuffolkjournal.com/category/world-news-at-suffolk/">World</a>
<ul class="sub-menu">
	<li id="menu-item-28500" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28500"><a href="https://thesuffolkjournal.com/category/suffolk-climate-watch/">Suffolk Climate Watch</a></li>
</ul>
</li>
<li id="menu-item-20310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20310"><a href="https://thesuffolkjournal.com/category/ac/">Arts &amp; Culture</a>
<ul class="sub-menu">
	<li id="menu-item-6538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6538"><a href="https://thesuffolkjournal.com/category/ac/artscampus/">Campus</a></li>
	<li id="menu-item-6537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6537"><a href="https://thesuffolkjournal.com/category/ac/artsinboston/">Boston</a></li>
	<li id="menu-item-6536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6536"><a href="https://thesuffolkjournal.com/category/ac/music/">Music</a></li>
	<li id="menu-item-6539" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6539"><a href="https://thesuffolkjournal.com/category/ac/film/">Film</a></li>
	<li id="menu-item-6540" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6540"><a href="https://thesuffolkjournal.com/category/ac/theater/">Theater</a></li>
</ul>
</li>
<li id="menu-item-6532" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-6532"><a href="https://thesuffolkjournal.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-6542" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6542"><a href="https://thesuffolkjournal.com/category/opinion/staff-editorial/">Editor&#8217;s Word</a></li>
	<li id="menu-item-28494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28494"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-conservative-message/">The Conservative Message</a></li>
	<li id="menu-item-28495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28495"><a href="https://thesuffolkjournal.com/category/opinion/columns/the-liberal-think-tank/">The Liberal Think Tank</a></li>
</ul>
</li>
<li id="menu-item-6531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6531"><a href="https://thesuffolkjournal.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-20524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20524"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/">Suffolk Rams</a>
	<ul class="sub-menu">
		<li id="menu-item-22158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22158"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/baseball/">Baseball</a></li>
		<li id="menu-item-22159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22159"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/basketball/">Basketball</a></li>
		<li id="menu-item-22160" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22160"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/cross-country/">Cross Country</a></li>
		<li id="menu-item-22161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22161"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/golf/">Golf</a></li>
		<li id="menu-item-22162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22162"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/hockey/">Hockey</a></li>
		<li id="menu-item-22163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22163"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/soccer/">Soccer</a></li>
		<li id="menu-item-22164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22164"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/softball/">Softball</a></li>
		<li id="menu-item-22165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22165"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/tennis/">Tennis</a></li>
		<li id="menu-item-22166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22166"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/track/">Track &amp; Field</a></li>
		<li id="menu-item-22167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22167"><a href="https://thesuffolkjournal.com/category/sports/campus-sports/volleyball/">Volleyball</a></li>
	</ul>
</li>
	<li id="menu-item-15147" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15147"><a href="https://thesuffolkjournal.com/category/sports/journalprosportscolumn/">Pro Sports</a></li>
</ul>
</li>
<li id="menu-item-24808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24808"><a href="https://thesuffolkjournal.com/category/multi-media/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-28986" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28986"><a href="https://thesuffolkjournal.com/category/multi-media/su-news/">SU News</a></li>
	<li id="menu-item-29021" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29021"><a href="https://thesuffolkjournal.com/category/multi-media/suffolk-sports-report-multi-media/">Suffolk Sports Report</a></li>
	<li id="menu-item-28645" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28645"><a href="https://suffolksnapshot.wordpress.com/">Suffolk Snapshot</a></li>
	<li id="menu-item-28996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28996"><a href="https://thesuffolkjournal.com/category/multi-media/comics/">Comics</a></li>
	<li id="menu-item-28847" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-28847"><a href="https://thesuffolkjournal.com/category/multi-media/blast-from-the-past/">A blast from the past&#8230;</a></li>
</ul>
</li>
<li id="menu-item-29354" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29354"><a href="https://thesuffolkjournal.com/category/politics/">Politics</a></li>
<li id="menu-item-29803" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29803"><a href="https://thesuffolkjournal.com/category/the-suffolk-journal-podcast/">SJ Podcast</a></li>
<li id="menu-item-20412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20412"><a href="https://thesuffolkjournal.com/staff-2-schoolyear2020-2021/">Staff</a></li>
</ul></div></ul></div>					<script type="text/javascript">
						jQuery(window).load(function() {
							$body = jQuery('.parallaxcontainer');
							var s = skrollr.init({
								forceHeight: false
							}); 
							jQuery(".parallaxcontainer").css('height','auto');
							jQuery(".parallaxcontainer section").fadeIn(2000);
							s.refresh(jQuery('.homeSlide'));
						});
					</script>
					<div class="lf-mobile-photo"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/10/lgbt-pride-flag-redesign-hero.jpg" style="width:100%" /></div><div class="lf-full-photo"><div id='jump-arrow' class='jumparrow bouncearrow' style='left:20px;right:unset;'></div><style>#slide-mp .bcg {background-image:url('https://thesuffolkjournal.com/wp-content/uploads/2020/10/lgbt-pride-flag-redesign-hero.jpg')}</style><div class="parallaxcontainer"><div class="loading" style="position:relative;"><div class="parallaximagesloading"><img src='https://thesuffolkjournal.com/wp-content/uploads/2020/10/lgbt-pride-flag-redesign-hero.jpg'></div><section style='height:100vh;'><div id='slide-mp' class='homeSlide' style='height:100vh;opacity:1;'><div class='bcg' data-center='background-position: 50% 0px;' data-top-bottom='background-position: 50% -100px;' data-bottom-top='background-position: 50% 100px;' data-anchor-target='#slide-mp'></div></section></div></div></div><style>.parallaxcontainer { height: auto !important; }</style><div id="mainbody"><div class="content main"><h1 id="storyheadline" class="storyheadline">Opinion: Trump won’t protect my gay mom, and he won’t protect your LGBTQ+ friends, either</h1><div class="dividingline storystart"></div><p class="byline"> <a href="https://thesuffolkjournal.com/staff_profile/morgan-torre/" class="creditline">Morgan Torre</a>, Asst. Copy Editor</p><p class="longdate"><span class="time-wrapper">November 4, 2020</span></p><div class="leftside storybody"><span class="storycontent"><p><span style="font-weight: 400;">With a viral video of First Lady Melania Trump defending her husband’s contradicting stance on gay marriage circulating the week of the election, President Donald Trump’s opposition to gay marriage is being magnified, creating further stress for all members of the LGBTQ+ community and their allies.</span></p>
<p><span style="font-weight: 400;">“I was shocked to discover that some of these powerful people have tried to paint my husband as anti-gay. Donald is the first president to enter the White House supporting gay marriage,” Melania stated in the video.</span></p>
<p><span style="font-weight: 400;">The clips of Melania were accompanied with those of a woman with blonde hair holding what appears to be a chicken sandwich interrupting saying remarks like “huh” and “what,” clearly confused by what the first lady has said.</span></p>
<p><span style="font-weight: 400;">What followed is the less shocking statements by President Trump: clips from three separate events, in which he said, “I am not in favor of gay marriage. I am against gay marriage. I don’t support gay marriage.”</span></p>
<p><span style="font-weight: 400;">The woman with blonde hair appeared again, said “oh” and then laughed, seeming to have expected these statements from the president.</span></p>
<p><span style="font-weight: 400;">As the proud daughter of a gay woman, this video increased any anxiety I have already felt as election results roll in. If the president is re-elected, how do I know that my mom and her long-time partner, who are currently engaged, will be able to marry?</span></p>
<p><span style="font-weight: 400;">Tuesday night, there was a brief period of time when Trump was ahead in terms of the popular vote. I watched my mom, who has never been very involved in politics, with her eyes glued to the TV.</span></p>
<p><span style="font-weight: 400;">In the weeks leading up to the election, her and I had several conversations about this topic. She made comments to me about how no gay person should vote for Trump, and those who love their friends and family who are gay should not either.</span></p>
<p><span style="font-weight: 400;">I’ve heard the question asked, “well if those who are gay are scared they won’t be able to marry in the coming years, why don’t they just do it now, while they still can?”</span></p>
<p><span style="font-weight: 400;">My answer to that question is simple. Gay weddings should be allowed to be as beautiful and as celebrated as the weddings of heterosexual people. </span></p>
<p><span style="font-weight: 400;">I want, so badly, to be able to attend my mom’s wedding someday. I want to be her maid of honor, and for it to be a glorious day for her, for her partner and for everyone involved. I don’t want it to be a quick, rushed and forced ceremony in town hall that was done out of fear of not being able to have a wedding at all.</span></p>
<p><span style="font-weight: 400;">Is that demand too much to ask? Well, for President Trump, I suppose it is. As my family holds our breath, praying for the best result in this election, I hope that everyone who voted did so while thinking of the many who have a lot at stake, including and beyond my family and other families with gay members. I hope your votes were cast with kindness and empathy.</span></p>
<p><em>Follow Morgan on Twitter <span style="font-weight: 400;">@morganjltorre</span></em></p>
</span></div></div><div class="clear"></div><div id="content" class="content main"><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div tabindex="0" role="button" aria-expanded="true" class="commenttoggle fa fa-minus-square"></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id='commentsbody' class='widgetbody' style='display:block;'>


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">

If you want a picture to show with your comment, go get a <a href="https://en.gravatar.com">gravatar</a>.</p>





<form action="https://thesuffolkjournal.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><label for="spam_stopper">Spam Control Field. Please Ignore</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							jQuery(function(){
								jQuery('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="31519" /></p>






</form>









</div></div><div class="widgetfooter"></div></div></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://thesuffolkjournal.com/category/opinion/">Opinion</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://thesuffolkjournal.com/31454/sports/athletes-mobilized-to-get-out-the-vote-this-election-season/" title="Athletes at Suffolk, in the nation mobilized to get out the vote this election season"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/Capture-240x150.png" class="catstory-photo" alt="Athletes at Suffolk, in the nation mobilized to get out the vote this election season" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31454/sports/athletes-mobilized-to-get-out-the-vote-this-election-season/">Athletes at Suffolk, in the nation mobilized to get out the vote this election season</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://thesuffolkjournal.com/31452/opinion/opinion-the-patriots-should-be-sellers-at-the-trade-deadline/" title="Opinion: The Patriots should be sellers at the trade deadline"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/getty-images3-240x150.jpg" class="catstory-photo" alt="Opinion: The Patriots should be sellers at the trade deadline" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31452/opinion/opinion-the-patriots-should-be-sellers-at-the-trade-deadline/">Opinion: The Patriots should be sellers at the trade deadline</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://thesuffolkjournal.com/31450/opinion/opinion-studying-abroad-during-a-pandemic-is-a-great-opportunity-for-students/" title="Opinion: Studying abroad during a pandemic is a great opportunity for students"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/getty-images-1-240x150.jpg" class="catstory-photo" alt="Opinion: Studying abroad during a pandemic is a great opportunity for students" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31450/opinion/opinion-studying-abroad-during-a-pandemic-is-a-great-opportunity-for-students/">Opinion: Studying abroad during a pandemic is a great opportunity for students</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://thesuffolkjournal.com/31443/opinion/opinion-suffolk-should-reconsider-its-plans-for-the-spring/" title="Opinion: Suffolk should reconsider its plans for the spring"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/Syda-Productions-240x150.jpeg" class="catstory-photo" alt="Opinion: Suffolk should reconsider its plans for the spring" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31443/opinion/opinion-suffolk-should-reconsider-its-plans-for-the-spring/">Opinion: Suffolk should reconsider its plans for the spring</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://thesuffolkjournal.com/31360/opinion/opinion-amy-coney-barrett-should-not-be-on-the-supreme-court/" title="Opinion: Amy Coney Barrett is a disgrace to the Supreme Court"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/Amy-Coney-Barrett-Oliver-Douliery-Getty-240x150.jpg" class="catstory-photo" alt="Opinion: Amy Coney Barrett is a disgrace to the Supreme Court" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31360/opinion/opinion-amy-coney-barrett-should-not-be-on-the-supreme-court/">Opinion: Amy Coney Barrett is a disgrace to the Supreme Court</a></h5></div><div class="clear"></div></div></div><div class="clear"></div><div class="relatedstories"><div class="storymeta" style="margin-bottom:0px;"><p style="text-align:center;font-size:16px;line-height:30px;"><a href="https://thesuffolkjournal.com/category/opinion/politics-opinion/">Politics</a></p></div><div class="relatedbody"><div class='catrow catstory-position-1'><a href="https://thesuffolkjournal.com/31360/opinion/opinion-amy-coney-barrett-should-not-be-on-the-supreme-court/" title="Opinion: Amy Coney Barrett is a disgrace to the Supreme Court"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/Amy-Coney-Barrett-Oliver-Douliery-Getty-240x150.jpg" class="catstory-photo" alt="Opinion: Amy Coney Barrett is a disgrace to the Supreme Court" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31360/opinion/opinion-amy-coney-barrett-should-not-be-on-the-supreme-court/">Opinion: Amy Coney Barrett is a disgrace to the Supreme Court</a></h5></div><div class='relateddividervert catstory-position-2'></div><div class='catrow catstory-position-2'><a href="https://thesuffolkjournal.com/31357/opinion/opinion-the-importance-of-kindness-during-chaos/" title="Opinion: The importance of kindness during chaos"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/kindnessEXPORT-01-240x150.png" class="catstory-photo" alt="Opinion: The importance of kindness during chaos" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31357/opinion/opinion-the-importance-of-kindness-during-chaos/">Opinion: The importance of kindness during chaos</a></h5></div><div class='relateddividervert catstory-position-3'></div><div class='catrow catstory-position-3'><a href="https://thesuffolkjournal.com/31354/opinion/opinion-amidst-the-election-america-is-setting-a-poor-example-for-its-youth/" title="Opinion: Amidst the election, America is setting a poor example for its youth"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/11/getty-images-240x150.jpg" class="catstory-photo" alt="Opinion: Amidst the election, America is setting a poor example for its youth" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31354/opinion/opinion-amidst-the-election-america-is-setting-a-poor-example-for-its-youth/">Opinion: Amidst the election, America is setting a poor example for its youth</a></h5></div><div class='relateddividervert catstory-position-4'></div><div class='catrow catstory-position-4'><a href="https://thesuffolkjournal.com/31294/opinion/op-ed-term-limits-are-bad-for-voters/" title="Letter: Term limits are bad for voters"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/10/SJLogo-240x150.jpg" class="catstory-photo" alt="Letter: Term limits are bad for voters" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31294/opinion/op-ed-term-limits-are-bad-for-voters/">Letter: Term limits are bad for voters</a></h5></div><div class='relateddividervert catstory-position-5'></div><div class='catrow catstory-position-5'><a href="https://thesuffolkjournal.com/31252/opinion/opinion-listen-to-scientists/" title="Opinion: Listen to scientists"><img src="https://thesuffolkjournal.com/wp-content/uploads/2020/10/getty-images-fauci-240x150.jpg" class="catstory-photo" alt="Opinion: Listen to scientists" /></a><h5 class="relatedtitle"><a href="https://thesuffolkjournal.com/31252/opinion/opinion-listen-to-scientists/">Opinion: Listen to scientists</a></h5></div><div class="clear"></div></div></div><div class="clear"></div></div><div class="footerbar"><p><a href="https://thesuffolkjournal.com">The Suffolk Journal</a> &bull; Copyright 2020 &bull; <a href="http://snosites.com/why-sno/">FLEX WordPress Theme</a> by <a href="https://snosites.com">SNO</a> &bull; <a href="https://thesuffolkjournal.com/wp-login.php">Log in</a></p></div>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-77199029-24', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	
<script type="text/javascript">
__tlid = '897596766940037121';
__tlconfig = {hOverflow: false, vOverflow: false};
setTimeout(function(){(function(d,t){var s=d.createElement(t),x=d.getElementsByTagName(t)[0];
s.type='text/javascript';s.async=true;s.src='//cdn.thinglink.me/jse/embed.js';
x.parentNode.insertBefore(s,x);})(document,'script');},0);
</script><div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div><script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/thesuffolkjournal.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/thesuffolkjournal.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.5' id='wp-polls-js'></script>
<script type='text/javascript' src='https://thesuffolkjournal.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>

   </div>

</div>
</div>
</div>
</div>
</body>

</html>